22.05.2020 17:25, moderator14

Тест по теме «Выполнение алгоритмов для исполнителей».
1. Черепашке был дан для исполнения следующий алгоритм:
Повтори 12 [Направо 45 Вперёд 20 Направо 45]
Какая фигура появится на экране?
а) незамкнутая ломаная линия
б) правильный двенадцатиугольник
в) квадрат
г) правильный восьмиугольник
2. При выполнении какого из перечисленных ниже алгоритмов Черепаха нарисует на экране правильный треугольник?
а) Повтори 3 [Вперёд 50 Направо 20 Направо 25]
б) Повтори 3 [Вперёд 50 Направо 100 Направо 20]
в) Повтори 6 [Вперёд 50 Направо 10 Направо 20]
г) Повтори 6 [Вперёд 50 Направо 20 Направо 40]
3. При выполнении какого из перечисленных ниже алгоритмов Черепаха нарисует на экране правильный шестиугольник?
а) Повтори 6 [Вперёд 100 Направо 90]
б) Повтори 6 [Вперёд 100 Направо 9]
в) Повтори 6 [Вперёд 100 Направо 60 Направо 60]
г) Повтори 6 [Вперёд 100 Направо 20 Направо 40]
4. Черепашке был дан для исполнения следующий алгоритм:
Повтори 180 [Вперёд 45 Направо 90]
Какая фигура появится на экране?
а) правильный 180-угольник
б) квадрат
в) правильный восьмиугольник
г) незамкнутая ломаная линия
5. Черепашке был дан для исполнения следующий алгоритм:
Повтори 360 [Вперёд 30 Направо 60]
Какая фигура появится на экране?
а) правильный 360-угольник
б) правильный треугольник
в) правильный шестиугольник
г) незамкнутая ломаная линия
6. У исполнителя Калькулятор две команды:
1. прибавь 2
2. умножь на 2
Какое число получит этот исполнитель, если выполнит программу 122112 для начального числа 4?
ответ:
7. У исполнителя Калькулятор две команды:
1. вычти 2
2. умножь на 3
Какое число получит этот исполнитель, если выполнит программу 211221 для начального числа 4?
ответ:
8. У исполнителя Калькулятор две команды:
1. вычти 3
2. умножь на 2
Какое число получит этот исполнитель, если выполнит программу 121221 для начального числа 7?
ответ:
9. У исполнителя Калькулятор две команды:
1. вычти 4
2. умножь на 3
Какое число получит этот исполнитель, если выполнит программу 211221 для начального числа 8? ответ:

Всего ответов: 2

Похожие вопросы:

Иконка предмета
Информатика, 10.03.2019 15:30
Перечислите преимущества электронной почты перед обычной ( не менее трёх)
Ответов: 4
Иконка предмета
Информатика, 14.03.2019 18:00
Найти произведение чисел от 1до 10,в паскале
Ответов: 1
Иконка предмета
Информатика, 15.03.2019 10:39
Шоколадка имеет вид прямоугольника, разделённого на nxm долек. шоколадку можно один раз разломить по прямой на две части. определите, можно ли таким образом отломить от шоколадки часть, состоящую ровно из k долек. программа получает на вход три числа: n, m, k и должна вывести yes или no.
Ответов: 1
Иконка предмета
Информатика, 16.03.2019 12:03
Составить линейную программу в паскаль: вывод на экран фразы "скоро лето! "
Ответов: 2
Иконка предмета
Информатика, 17.03.2019 23:50
Переведите числа в двоичную систему счисления. 1) 200 2) 489 3) 543 4) 950 5) 1025
Ответов: 2
Иконка предмета
Информатика, 20.03.2019 06:50
Синформатикой: звучит так: 1.нарисуй в окне цепочку цифр, для которой истинно утверждение: вторая и третья цифры в этой цепочке разные. 2. нарисуй в окне цепочку цифр, для которой ложно утверждение: вторая и третья цифры в этой цепочке разные
Ответов: 2
Иконка предмета
Информатика, 21.03.2019 21:52
Преобразовать двоичные числа в десятичные 100000 1011111. восьмеричные в десятичные 3573 13. в десятичное 75 в двоичное. десятичное в восьмеричное 2092. десятичное в шестнадцатиричное 6139. шестнадцатиричные в десятичные 1752 5d 67
Ответов: 1
Иконка предмета
Информатика, 28.03.2019 03:40
Даны две переменные вещественного типа: a, b. перераспределить значе- ния данных переменных так, чтобы в a оказалось меньшее из значений, а в b — большее. вывести новые значения переменных a и b.
Ответов: 1
Иконка предмета
Информатика, 28.03.2019 04:00
От разведчика была получена шифрованная радиограмма, переданная использованием азбуки морзе. при передаче радиограммы было потеряно разбиение на буквы, но известно, что в радиограмме использовались только следующие буквы: т - "-" р - ". - ." и - ". " й - ". - - -" п - ". - - ." определите текст исходной радиограммы по полученной шифрованной радиограмме: . - - . - . - . . - - . - - - в ответе укажите, сколько букв было в исходной радиограмме.
Ответов: 2
Иконка предмета
Информатика, 30.03.2019 07:30
По какому признаку сгруппированы предметы автомобиль, самолет, стул, стол
Ответов: 1
Иконка предмета
Информатика, 01.04.2019 11:40
Марине яблочковой не нравилось, что каждый раз учительница называет её фамилию последней. когда учительница узнала об этом, она сказала: "марина, если ты составишь новый список учеников, я буду пользоваться им". марине отсортировать список так, чтобы её фамилия оказалась первой. восстановите также и список учительницы. исходные данные: марина яблочкова катя арбузова валя стрелина роберт щукин коля белкин лена волкова дима иволгин серёжа тополев яша арбузов
Ответов: 3
Иконка предмета
Информатика, 01.04.2019 19:00
Каждый из семиклассников является читателем, по крайней мере, одной из двух библиотек: школьной и районной. из них 25 человек бурут книги в школьной библиотеке а 20 в районной. сколько семиклассников являются читателями обеих библиотек? ответ поясните и проиллюстрируйте
Ответов: 3

Вопросы по другим предметам:

Категория
Математика, 16.10.2020 02:48
Категория
Русский язык, 16.10.2020 02:48
Категория
География, 16.10.2020 02:48
Популярные вопросы
Вопросов на сайте: 13767437